Why is my Snap! not working! Variable pallet is black

So, I was working on one of my projects and suddenly Snap stopped working. At this point, I save it and reopen it. When I tried to switch between the sprites they were not responding and the variable pallet went black. I don't know what I am supposed to do.
"All the suggestions are recognized and encouraged"

Yikes. What kind of project where you working on? It would be great if you shared your project and put the link here. If you need help, read this article. (Or, if you can't do that, go to your projects, find the one that is broken, and click share. Then, copy the link in the URL bar.)

I think I've seen this, but I want to be sure.

This is the link

I'm guessing the problem is a block name. I'll look into it.

Thank you

You have like 50 duplicated blank inputs with no types.

What did you do to break it so hard lol

what do you mean by that?

fr bro

You might be able to recover a previous version

Select File then Open and then single click on the name of your project
Then click on Recover button and you might be offered previous versions that you can open

If you manage to recover using this method, I recommend re-saving it under another name

Thanks for the suggestion but, I am out of luck with that option. I have already tried it.

In the XML.

can you do it for me, please??

I tried, but I messed up and put an extra < somewhere.

its fine just don't save the mistake

I have to redo it because my texteditor doesn't save directly to a file.

Appreciate your work bro. Thanks, a lot. Please do tell me if you can fix it.