Strange bug causing corrupted program

When I was working on this program (It's a WIP) the screen started glitching a weird polygons in random colors started covering my screen. after saving almost all of the images in my project were corrupted and I wasn't albe to recover any of the. After meticilously going through all the sprites and fixing them, I found that there is a very annoying start button covering my entire program. This start button isn't part of any sprite, or even the stage and as far as I can tell, it's impossible to remove and my program is corrupted. Does anyone know what I can do about this, I really don't want to start coding the entire program again.
Similar thing also happened here:
I have absolutely no clue how to reproduce this bug, but an image of what the polygons look like are here:

I've never seen anything like this before! Did you get a snapshot of the developer console when it happened?

first, don't close the tab, we may be able to recover the project much easier with the tab open.

Also just using the "clear" block in the pen category got rid of the huge start button.

that fixes it, thanks

yea I still have the original tab open

nope, How do I do that?

ctrlshifti on the keyboard

Once you go into the dev tools (inspect element), go into the console tab. Take a screenshot and send it so we can see any errors.

After you do that, type this in


And then hit enter. That should download the project.

I know, this topic a little old but the issue is getting so annoying now that I pretty much can't use snap.

Also I can't figure out how to send images as a reply so here is the error:

  1. Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform

  2. A page or script is accessing at least one of navigator.userAgent, navigator.appVersion, and navigator.platform. Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.

To fix this issue, replace the usage of navigator.userAgent, navigator.appVersion, and navigator.platform with feature detection, progressive enhancement, or migrate to navigator.userAgentData.

Note that for performance reasons, only the first access to one of the properties is shown.

1. 1 source
    • Learn more: User-Agent String Reduction

This the link that I am sent to when I click on the "one source" link

You should be able to put images in posts. To do that, drag and drop the image into the text box, or if it's on the clipboard, you can just paste it in. If none of that works, you can click the picture icon to upload an image.

If none of that works, you can just create a project with the screenshot in it.

hmm It works now before is was saying a message like "sorry but you are not allowed to put images in posts"

You probably just got to trust level 1. Don't worry, trust level 0 is just to keep spammers away.

What you copied isn't actually the console, that's some issues tab. The console is the top part of the image. It looks like it has something to do with getting the imageData. What file format are your images (png, jpeg, etc).

Oh ok, this is what the console says:

all the images I uploaded were png I'm pretty sure

Does running this


result in an error? (type it into the console, and press enter)

Nope, it runs fine and outputs "undefined"
But I decided to upload the project and see if it actually worked fine:

all the sprites are gone and this project is missing huge chunks of code

also for comparision this is what the project was before the bug: