Saving which produces &editMode&noRun flags mysteriously

I'm teaching Snap to 14yos in Alice Springs, Australia. Because I setup a new account for my class I couldn't post here. So I wrote to contact and Brian wrote back to me straight away and changed the permissions so I can now post here. Thanks Brian!

I ask students to do projects (alonzo game) and post the URL to me after Sharing. When I received their URLs some of them had correct userID and project name and also the &editMode&noRun flags. I read the manual pp. 124-5 so now understand what those flags are for. But I couldn't understand how the students were saving to get those flags. Some of the URLs with those flags worked (I could run their projects) and some didn't, I got an error message "Could not fetch ... does not exist or is private".

Brian found a possible answer for me. They are opening a project on the community page, then clicking See Code. When I did this I got this URL!&editMode&noRun

So, perhaps some of my students are doing that and then changing the Username to their own, deleting the project they have loaded and doing the project I have set them. I'll have to make further investigations to see if that is what is happening.

When you share the project, the url is generated, but when you just save it (it's unshared) it won't give you the url. You need to tell your students to make sure their project is shared. If it's shared, it will only be accessible via link, but if you make it public, it can be found on the snap website without knowing the url.

This URL appears quite naturally, without any editing, if your student navigates to the community site page for their own project and clicks See Code.

Thanks Brian, I can duplicate that behaviour on a test file. I never asked my students to Publish, only to Share, so never thought of that possibillity.

This bad URL problem is threatening to wreck my curriculum since too many students are failing to send me their work. Today I had 5 students send me URLs that worked and 5 with URLs that failed. Here is one of the fails

The error message says "Could not fetch project shapes. This project does not exist or is private" (it won't let me embed the image).

It does exist and it's not private because it has been Shared

(1) Why would it fail if the student had fetched it from the community page? I don't understand that from my initial communication with Brian. The Username=fnugget&ProjectName=shapes part is correct.
(2) For students who had previously sent URLs with &editMode&noRun endings I went through the scenario of them fetching it from the community page and all I got was puzzled looks. I'm pretty sure that 5 students are not doing that since it is more difficult to what I am asking them to do.
(3) I showed them again how to Share and then post it to my blog but the proportion of bad URLs I'm receiving has increased
(4) Sadly, the conclusion I'm reaching is that anything that involves 4 steps (Save to the Cloud, go back in, select the file again, click Share) is too difficult for about half of the digital generation.
(5) Next lesson I'll sit down with a bad URL student and ask them to save and share while I watch.

I am of no authority here but - you could try asking them to go to their profiles and copying the link from there, it seems they are copying the url straight from the editor still instead of the project page. I wouldn't know how to explain anything else.

You mean this project?

The link in your post works fine for me!

I wonder if the problem is happening when you load their projects, rather than when they save them. Could you try flushing your browser cache and then try loading one of the failing links?

That's the one, Brian! But I still can't load it. Cleared the browser cache in Edge, didn't load. Then tried Chrome and Firefox, same error message.
I don't understand why you can load it and I can't when I can load other Snap URLs that students send me.

I went back and looked again at the 5 URLs that failed:
2 cases of students not Sharing (UserName absent), obvious student error
2 cases with &editMode&noRun endings to URLs with UserName
1 case which has been Published rather than Shared project?user=jaynugget&project=pen (I also belatedly looked for it in the community page but it had scrolled off the top 20)
In those 3 fail cases I got the same message, "Could not fetch project shapes. This project does not exist or is private"

I have 6 URLs which I can open, they all have UserName & ProjectName without the &editMode&noRun endings, they have Shared as I asked students to do.

Well, if you manually delete those flags from the URL, does it then load?

No they don't load for me, with or without those flags, the first case I posted above (worked for you, didn't for me), here is the second case:
Snap! 7.3.0 (

Oh. Duh. It works for me because I'm an admin. I didn't realize it'd let me load unshared projects.

I have to think this is all about sharing or not sharing. (If a project is published, it's shared too.)

Huh, I think I remember jens say that he didn't have access to unshared projects... I guess none of you knew? (You, as in, the snap team)

But if they are not Shared how is it possible for the UserName and ProjectName to appear in the URL?

I've prepared a new worksheet for Monday's lesson, here are the steps that students need to do:

  1. check they are logged in
  2. Save As …
  3. Select the Cloud, type in the project name and click Save
  4. Click Save As again
  5. Select the project name in the list of projects and then click the Share button
  6. Copy the URL and paste it to the teacher’s blog

I think it is steps 4 & 5 that student's find difficult, they don't have to do that when saving a Word doc or sharing a Scratch file and adding it to a Studio setup by the teacher. Also there is no automatic saving with Snap so some students lose it all. You are bound to get some students who can't follow 6 steps. eg. I have one autistic + ADHD student who has difficulty reading one step. In a class of 23 I can't sit with them all.

After reading this, I came up with an idea that I think would solve this problem. I think that a new option "save and share" would be better. When you click it, it will run the regular save function, open save dialog, or save the project. Once it's saved, a new dialog will ask you if you are sure you want to share the project. This might help reduce the amount of confusion about the current steps to share a project.

Yes, of course that's what we should do. This is one of those things that none of us really disagree about, but we do disagree about how urgent it is. (Jens argues that users will really click the Share button on the project's page on the community site, not understanding that the community site is great for browsing but not for editing one's own project, compared to a direct link.)

Maybe this thread will help actually get it to happen.

shapes is the title of the project, they just did not share it with you, you are literally over reacting. Chill

you only get logged out if you log out

just press save, it will be way easier, plus it skips step 3

Yeah but why? also step 5 doesn't work (or at least not for me)
Edit: This is not inappropriate. Don't flag people if they did nothing wrong!

:person_facepalming: It appears the first time the project is saved
Ex: My "Among Us Story" (don't ask) isn't shared, but the name and project name is there

I'm offended. I have both ADHD and I'm a little autistic, but I don't have these problems?
Or maybe they are higher up on the scales...

All my saved but unshared projects have this URL:

that's because when ever you make a new project, it goes to that link. When you save it and reopen the project, it doesn't have the link. Refresh while in there, and see that all of your blocks are gone, because you're not in the editor for the project you were just working on.

example, go to one of your saved but unshared projects, you'll notice that they have a different url