I can't edit project notes!

Please fill out these questions for all feature requests and bug reports. If you're requesting a feature, please let us know why this feature is important or useful, not just what it should do.

  1. What browsers show this problem? Google Chrome
  2. Please share an example project (if possible). All of my projects
  3. Describes the steps to reproduce this issue. Try to edit the project notes
  4. What does Snap! currently do? Not work
  5. What should Snap! do instead? Work

I tried doing it from both the editor and the project page. It doesn't let me click on the notes on the project page, and when I do it from the editor, it doesn't save!

This is probably intended. How to fix? Well, go to the editor, click on the button (or drop-down) beside the cloud button, choose Project Notes, edit it and finally, save it. :stuck_out_tongue_winking_eye: Another option is editing the xml file.

You did not read my post

Well, have you read my post? You can save it by editing the xml file. How? Export the project to your device, open it with a text Editor (Notepad, for example). At this point, you will see notes and /notes written between angled brackets(Snap! does not let me write that here). Type what you want to write in the Notes there and save it. Open it with Snap!. That's all!

Yeah, but you're still supposed to be able to edit the notes directly from the project!

You can use this block-
Test4 script pic

One more thing, this does not happen for me on Chrome latest version (Version 81.0.4044.138). My OS is Windows 10 Pro. What about you?

As you may know, we have a problem: every so often a user saves a project and the saved file has zero length. There is some evidence that changing the project's name or description is one way that problem is triggered. So I would guess that your inability to do it right now is deliberate.

We are now about a week away from the deadline for students to submit their final projects for grading in AP CS Principles classes. So for the moment our first priority is to prevent projects getting lost, e.g. by noticing when a zero-length project is being saved, rather than debugging the underlying cause. Once past the deadline, we'll be experimenting with whether we can trigger the bug, and so you'll probably be able to edit again.

Are we allowed to edit them now? I just tried it and looks like just saving the project after editing worked.

Then I guess it's okay! Although I don't know that the problem has been fixed...

Okay. Thank you.

You can edit them from within Snap!, no problem. What's been disabled is editing them from the project page in the community website.

Okay. Thank you. :smiley: