Costume shown in image editor doesn't match real costume

  1. What browsers show this problem?
  2. Please share an example project (if possible).
  3. Describes the steps to reproduce this issue
    Enter image editor trying to edit costume "acqua" of sprite "acqua"
  4. What does Snap! currently do?
    The image shown in the image editor doesn't match the costume's
  5. What should Snap! do instead?
    Show the correct costume image

I think it might be your source images (or something going wrong when you import them)

I exported acqua - and it looked like this in MSPaint

But after I cropped it to get rid of the extra white and added it back into the project - it looks fine and can be editied

The project is imported in Snap from an original BYOB project. I guess the problem is in Snap's import procedure (but it is very old part of Snap; it is based on Scratch 1.4 file format that I have never understood :slight_smile:)

Weird that the costume is correctly managed by Snap but it is not fully editable.

Can you send me a link to the original BYOB file - just for interest sake :slight_smile:

Here you go

Unfortunately the BYOB format import procedure has an even more serious problem, where all costumes become small red squares :confused:

Well - its imported fine on my computer

Are you too running the online version?

Yes - standard Snap!

Weird. I don't think a specific Chrome version or OS should have an impact on this. Anyway, if someone wants to give it a try, my OS is macOS Catalina and the Chrome version is 86.0.4240.80 (Official build) (x86_64)

JFI I'm running Vivaldi on Win10

I installed Vivaldi both on macOS and Win10 (in a virtual machine) but to me the result keeps being the same: when I open the ypr file, the costume of the acqua sprite (when edited) is just a cyan square in the top left corner in both OSs

Just to prove its OK for me

Chrome.86@Win10, I see this problem.
The image stored in the costume has a dimension 960x700 pixels.
It seems to me that only the part of the image is shown in the built-in editor.

Usually, Snap! trims the excessive parts of the image during import, so the editor is fooled by the extra data.

Everything works better in retina mode :wink:

I trust you :slight_smile:
Just to be clear: this is when you import the original ypr file I sent you, not after you exported and reimported the acqua costume, isn't it?

Yes I have the same idea, because the sprite just renders fine on the Stage. It is just weird that the image is correct but I can't fully edit it. Just to know: you have the same problem, haven't you?

Yep - file new - file import xxx.ypr

Thanks. I'm going to try with Vivaldi and my old Win 10 PC (no virtual machine)

I just tried it on myu old Win7/Chome and that was fine
Also, Ok for me using Win10/Chrome

Same result on my real win 10 PC: with Chrome wrong costume... (instead Vivaldi doesn't seem to be able to import the ypr)

The ypr.js procedure where developed by Nathan Dinsmore, that I guess is not around since a while.

So it is likely I'll have to stick with it :slight_smile: