Cannot save project to cloud or import project

What's problem you are encountering?
When I try to save my project, it just says "Saving project to cloud..." and does nothing. (I have tried to find solutions but no one else seems to have this error msg)
Also I have ran into this issue almost every single time I try saving in the past, but I found a workaround where I export it and then drag it back in and it worked, but this time it doesn't.
I have exported the project and tried importing it but it says "Load failed: TypeError: Cannot read properties of undefined (reading 'loaded')"

What have you tried that didn't work?

  • Saving to cloud
  • Importing project as xml
  • Checked for syntax errors in xml
  • Refreshed and hard refreshed
  • Could not find any posts with this error message
  • Export project media only/without media/as cloud data doesn't even work

Post a project example, link, or screenshot:
cannot include links......

Welcome to the forums, tamuraki! Have you tried waiting for it to say "saved"? Was the project the saved version when you opened it again? It takes longer for bigger projects to finish saving.

I have waited for like an hour and nothing happened.
Usually when I get the "Saving project to cloud" message, it does nothing.
When it says "Uploading xMB" then it works.
My project is around 7MB btw

Do you mean exporting i.e. saving to disc?
Did you try to re-login (Logout / Login) just before saving?

You may look at the browser console/error log, to check, if there are problems with your internet connection.

Yeah I meant exporting as xml.
Relogging didn't do anything.
I can't check the console anymore because I hard refreshed the tab with the changes.
I just need to be able to import the xml file.

Are you working on an iOS system? Snap!’s IDE saying “Saving project to the cloud” and then locking up is a well-known problem.

In my experience it doesn’t happen as much as it used to, 8 months ago or so. At that time it happened so frequently, I even built my own auto-save function (probably a remix of someone else’s work - I don’t remember the details). Alas, that stopped working every time the red button was pressed, so in practice it didn’t help much.

It may help to wait a while (like 5-30 mins.), meanwhile go do something else even on the same system, then try again. Perhaps saving to Computer still works (that may be the same as Exporting the script, I guess). If you’re unlucky, you’ll loose the project, or at least every change you made from the latest successful save.

My suggestion: save often.

The problem with that is ios doesn't actually download the xml file, it opens it in the browser, so you need to do some weird stuff to actually save all the conents.

After selecting Save To Computer I’m asked if I want to download the XML file (-> yes). Now it’s saved in my iPad’s Downloads map. Subsequently I can Import it into Snap!. And the code still works. No weird stuff … am I missing something?

I just tested it, and the issue is only there in brave, not safari (any browser on ios uses safari, because apple doesn't like anything but safari on ios, but that doesn't mean all the features in safari are in every browser).

Also, I noticed that when I export a project in brave (on ios) it gives me base64 image data, not xml data.

edit: it seems to be the thumbnail

I'm using Chrome on Windows 11.
I've waited a long time already so it doesn't seem to do anything.

Is there any causes to this error when trying to import? (Load failed: TypeError: Cannot read properties of undefined (reading 'loaded'))
Like what does reading 'loaded' mean?

I don’t really understand what you wrote, and probably wouldn’t know a solution. Perhaps Snap! staff can help.

This is an error regarding parsing the XML file, I think.
What version of Chrome are you using?
What shows up in the console when you try to save your project?
What shows up when you try to load it?

My Chrome version is 120.0.6099.130.
I can't try to save it again because I closed the tab.

I get this message when I try to open the XML file:
[Violation] 'requestAnimationFrame' handler took 891ms at snap.html:46

The function at line 46:

loop = (timestamp) => {
    if (timestamp - lastTime < 1000 / FPS) {
    lastTime = Math.max(
        lastTime + 1000 / FPS,
        timestamp - 1000 / FPS

edit: it seems this message appears in console when i open any project

Are there any other errors?

Nothing else appears in the console.
The only error is the message box that says Load failed: TypeError: Cannot read properties of undefined (reading 'loaded')

This message appears when something took a long time to be done, loading pprojects can take some time, so that's why this happens when you load any project.

is your XML file corrupted?

I don't think so. I've exported it multiple different times, skimmed through the xml file, and put it in an xml validator.
I can load other xml files without a problem though so there might be something in the xml that I missed.

If you want to take a look yourself:

Your XML file's syntax is valid, but Snap! may have saved the project incorrectly causing the project file to fail to load. This happens rarely; the only time I've seen it is when the cloud went down for a few hours a while ago. Perhaps someone who knows the Snap! XML format better than I can help fix your project.

There are only recovered project blocks. There was no costume data in the XML.