Word/Text to Binary Converter (Help!)

Link: Snap! Text>Binary (berkeley.edu)

Alright, there is a bug in the code that I can not figure out. Could someone please review the code?

The issue:
When you enter the text and press "enter" it always come out with the output 010000010 (A) which is the first item on the binary A-Z-a-z list. Help?

I am extremely stupid.

Its still not working, now t just outputs the inputted word. Its not converting it.

Does this work for you?


There is a problem: Yours is not always accurate.

What do you mean?

Edit: Do you mean it not padding to a power of two digits?

Well when i convert a word, sometimes it doesnt convert to the correct binary or it reports the same letter in binary twice.

Can you give an example?

I wasnt able to replicate it when I tried again. When it first happened I entered "cause" and it displayed the binary for a instead of c

So you typed in "cause" and got "1100001 1100001 1110101 1110011 1100101"?

Yes. It also happened when I typed "cant"

both ca word.

Apparently capital "C" gives 1000011, which is the reverse of lowercase "a"'s 1100001.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.