Why doesn't this replace work?

(this is a script pic that you can drag into editor and import that bad behaving block
So I'm makaing a new os featuring a function to compile os-unfriendly blocks to os-friendly one
But the substitutor doesn't quite work!

Maybe share a link to the project with just this test script so we can debug it ourselves and report back.

You can drag the script pic into an empty project.


the culprit:

I still can't import either of these because they're just images.

Click on the image to expand it to it's full size (original image), then drag that into snap. It will try to import the script.



Still doesn't work. And how would Snap even know how to read a .png and convert it into blocks? Such a feature isn't documented in the reference manual.


drag to scripts area

drag to scripts area

That's what I've been doing but Snap just immediately imports it as a costume.

maybe your computer doesn't support that.

This tipped me off, but it wasn't the computer, it was the browser (Firefox).

when you import it as a costume, do you see a little icon like this?
if so, just right click the costume and select "get blocks".
If not, make sure to click on the image in the forum to expand it to full size, then drag the image into snap.

And how it gets the blocks from the png file, is because snap put the blocks inside the file as metadata (that's why script pics can be large).

@d4s_over_dt4 I do agree with @bloct that you should share a project instead of just a script pic when looking for help. Script pics should only be used when a user is demonstrating some script, or giving a solution.

Ok,but I have already found an alternative

That has never worked for me - I get

I have to right-click and save the image and then drag the saved image into Snap!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.