What happened here

what happened in this pic
what the heck
its just a hole in the script

I don't know. What version was it?

newest version.

6 or 7

  1. 7 is not out yet.

7 is currently in public in Snap Dev.

I don't use snap dev.

That has happened to me before. In 6.9.0 and 6.8

do you know how to fix

that has happened when I first joined snap, so snap 5.4.5 (or earlier). To reproduce that, just wrap a loop around a currently running script, although, I can't seem to figure out how to get the gap to be one block tall.

You simply move the objects inside the c shape out and drag the c shape off then re put it back on and put the rest of the stuff back.

I had the bug again with a warp block but it fixed it self

It isn’t that big of a deal as it does not effect how the project runs or the code itself.

And it's easy to fix on your own.

yay but it can happen without in interaction meaning it does this on its own and it breaks the script

I don't know what happened but the script won't work.

I told the mods to close the topic its not that bad and I fixed it.