Updating Snap! to the latest version

I'm having an issue where I can't update the in-browser version of Snap! to the latest version permanently. My browser is defaults to Snap! version 8.0.0. I can update it to version 9.0.5 by holding shift and pressing refresh, but whenever I load another Snap! file, it reverts to version 8.0.0 even though the file I'm loading is made on version 9.0.5.

This is annoying because I'm a teacher and need to grade hundreds of student Snap! submissions and I have to shift + refresh every time. Otherwise, their code will have incompatible blocks. For example, in version 8.0.0, the equals block is fixed at two arguments: [] = []. However, in version 9.0.5, you have the ability to increase or decrease the number of arguments. Therefore, if a student uses any block that had a feature change between versions 8.0.0 and version 9.0.5, their program simply won't run as intended.

Does anyone know of a way to update Snap! on my browser permanently? Thank you in advance.

If it keeps going back to 8.0.0, just clear the cache. You can go into settings to do that, or by pressing ctrl + shift + i (open dev tools, can also be opened in the browser menu), then right clicking the reload button and pressing "Empty Cache and Hard Reload". I don't know about firefox or safari, but this works in chrome.

Thank you for your reply. It works for that one instance, same as the shift + refresh. If I open up another Snap! tab, it unfortunately still reverts to version 8.0.0

It sounds to me like you are using a bookmark that points to the wrong place. Are you opening a project from our community site, or what? I.e., how do you start Snap!?

Then the best option would be to clear the cache from the browser settings. Here's instructions for chrome. Note: you don't have to clear cookies (in fact, keep them to stay logged into all your sites)

I think you're right. To open Snap, I go to google and search for "snap berkeley" without the quotes. Then I click the first result, which takes me to the Snap! home page (with the Alonzo banner). On the top banner, I click Run Snap! This opens up Snap! version 8.0.0 for me. However, when I right click Run Snap! and open link in new incognito window, it opens Snap! version 9.0.5.

When grading, I click on project links that students submit on Canvas. From now on, I will just open those links in a new incognito window. That seems to solve the problem.

I gave that a try, clearing all the caches from the beginning of time, but it did not work. I closed all current Chrome tabs & windows and reopened them and it still loaded Snap! 8.0.0. Thank you though, it was worth a shot. I found a solution though, so it's all good. I just need to right click the Snap! links and open them in an incognito window.

in Chrome, did you try clearing the browsing data (only the cached images and files) once. Then close and reopen Chrome, this should totally do the trick:

Yes, I tried that just now. I attempted to upload a screenshot to show that doing it again would free up less than 1 MB, but I can't embed images in my posts.

After I've done that and closed all Chrome windows and tabs, it still loads Snap! 8.0.0 (indicated by the name shown in the tab itself: Snap! 8.0.0)

I really appreciate all the help I'm getting, thank you. I did find a fix by opening Snap! in an incognito window. Clearing the cache should have fixed it, but somehow it didn't so it might be something janky on my end.

hmm... another thing you could check is whether you've installed Snap! as a PWA (progressive web app) on your computer, because that, too, will aggressively cache all the files. If you have a Snap! icon on your desktop or check your Chrome apps and you do find Snap! in there you also need to first uninstall the Chrome app before clearing your cache, and then re-install it. Sadly, web-programming is kinda vodoo-ish and doesn't make a whole lot of sense. "Progressive" web app doesn't mean that it dynamically loads the latest sources - as one might expect - but that it's somehow "progressive" in the sense of "modern/cool". But that's one more thing you might want to check.

Yes, that did it! Yesterday I installed the desktop version of Snap! trying to find a fix. I've uninstalled that and cleared my cache again afterwards, and now whenever I load up Snap!, it loads in version 9.0.5. Thank you all for your expertise!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.