The Percent Problem


Some blocks have a % symbol, like this one: Screenshot 2024-04-09 204952
but when I try it on custom blocks, (due to Snap!'s code for inputs) it enables an error, and I have to use $% to get it, but it gives me thin text. How do I get a normal % symbol?

P.S. I tries using the Snap! 10.0 'Blocks all the way' option to find out but nothing is wrong. I tried putting an input after it, which should've been broken, but nothing was wrong. I am confused.\

Simple answer, the issue is fixed in snap 10.

edit: after some testing, it seems that if you stick some text after %, it will become an input, but if you put it by itself, or text before the %, it will just be text. This is the behavior in snap 9 and 10.

I tried it before and it gives me a blank upvar

I'm not quite sure what you're doing, because making an input and then a title text after it that just says "%" works fine

This is what I get

how did you do that

I think it was '%%' that caused the blank upvar. will you fix it

Just use ‰, or ‱ for that matter - nobody reads the fine print anyway :smirk:

Copy the below code and use it on your custom block...


It uses the zero-width-space before the percent sign, therefore won't break.

‰ and ‱ means per mille (or per thousand) and basis point (per ten thousand) respectively. Others might read these, others don't care. This will confuse people "which percent" symbol is it.

Nah, as @ego-lay_atman-bay says, it works fine as long as nothing comes after the % in the same word. If you really need something screwy, just leave out the % and edit it in once the Block Editor starts.

It was a joke

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.