Snap libraries not working on a raspberry pi 4

I've tryed to use Snap! on a Raspberry pi 4, but any projects that use libraries that contain the primitive block come up with this error:


My browser is Chromium Version 78.0.3904.108 (Official Build) Built on Raspbian, running on Raspbian 10 (32-bit)

Are you just accessing the normal Snap! website through Chromium or are you using it offline?

I'm using the normal online Snap!

Try refreshing the cache, e.g. hard refresh.

I tried a hard refresh but it stayed the the same. This has been happening ever since i tried Snap! on the raspberry pi.

Can you try creating a new project and just import the list library and try using the sort reporter and see what happens

Wait, check the console for any errors related about loading a url.

The same thing happens as before. Going offline till tomorrow but will check replies then.

Try installing and using Vivaldi and see if problem disappears.

Remember always to test with a brand new project just in case its some issue with an older project

So, first of all, the symptom you're reporting is perfectly normal if you're running a project created before Snap! 7.0 in a Snap! 7.0 or later. So, if that's the situation, don't panic.

The way you fix it is to open the project, then reload the library/-ies. (Then save the project, if it now works.) (Someone did say that already, but I'm afraid that in the huge flurry of conflicting advice you might have missed it.)

If that doesn't solve your problem, please run Snap!, click on the Snap! logo in the top left corner, choose "About," and tell us what version of Snap! you're actually running.

I tried it on a newer version of Chromium and it worked. (And a newer version of Raspbian)

It turned out that it thought there was a syntax error in extentions.js but my browser must have been too old.