"Reporter didn't report" in run block

Please fill out these questions for all feature requests and bug reports. If you're requesting a feature, please let us know why this feature is important or useful, not just what it should do.

  1. What browsers show this problem? Chrome
  2. Please share an example project (if possible). https://snap.berkeley.edu/snap/snap.html#present:Username=18001767679&ProjectName=task%20flow&editMode&noRun
  3. Describes the steps to reproduce this issue. Click the mycatch block.
  4. What does Snap! currently do? With visible stepping, I found that the issue is in the run block. I rearranged the say block and found no problem there. If the continuation is not empty, it works as intended.
  5. What should Snap! do instead? End the script because the continuation is empty.

Is this bug a security concern? If so, please do not post security concerns directly to the forum. Please email us at contact@snap.berkeley.edu. Thank you!

I just tried run (run (#1) input names: (#1)) w/ continuation and reproduced the error.

There's a known and documented bug about call/cc not working as the last thing (i.e. a tail call) in a procedure. Is this that?

yes, that's the bug. Fixing now....

Awesome! I can take the IGNORE block out of CATCH!

Oh, that's why that was there. :thinking: :bulb: :point_up: :smile:

I've fixed it in the beta: https://snap.berkeley.edu/snapsource/dev

Confirmed. A new iteration library will be in the PR with the APL library. :~)