Rename this block plz

This block is not crystal clear !

This one is:

Hmm. The way we have it is more traditional in programming languages -- it's what I learned as a kid. (Back when dinosaurs etc.) We could put STEP BY instead of STEP in the first version, too. If we were going to change it, maybe STEPPING would be clearer than STEP. (I bet you translate it already into a participe present.)

One advantage of the current order is that it puts the start at the start and the end at the end, with the step to get from one toward the other in between. (Is it because of the C/Java/Javascript/Python/etc FOR (I=0; I<10; I++) that you think your way is clearer?)

i don't know, if i read the block it's like "for i = 1 step" "1 to 10"

"step by" would be a good compromise

Ask the opinion of a young programmer who does not know any other programming language

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.