Project cant be loaded

I made a game for my computer science programming class and everything worked after i finished and saved it. A couple of hours later i went to open it again because i had to write a description of my program but when i tried to open it all i got was "Failed to find resource: /api/v1/projects/andre%20byers%20jr//metadata". How do i fix this?

Oh dear. Sorry you're having this trouble.

What is the name of your project?

P.S. In general, the first thing to try is, in the Open dialog window, find the project name and click "Recover." That will present a few old versions that might load.

My project was called "9w project" it was a simulation of a bat similar to flappy bird

i can see the project on the snap website but its not there when i go through the dialog window

Apparently the project has been renamed to an empty name. Maybe @bromagosa or @cycomachead can find it, but it's beyond my cloud expertise.

OK! you should be able to load your project again. I've put it back at it's old name.

thanks man