Not leaving traces with the mouse down

I have a silly little starter exercise to warm up my class, where they draw with the mouse. The simple form of the script we develop is this:

untitled script pic(1)

In version 6.2 (current when I last taught my class), this worked fine, but now (7.1.4) it no longer works. The sprite will follow the mouse just fine, but I only get occasional little dots and spurts of lines. If I change the 'got to' block to go to a 'random position', the sprite dashes all over and will draw when the mouse button is down and stop when it is up, as expected.

If I switch the logic and put the pen down initially and just change the pen color based on mouse state, it draws lines just fine until I depress the mouse button.

I've tried this in Firefox (95.0.1), Safari (15.1), and Vivaldi (5.0.2497.48).

Sprite is shown? If so it detects as click on sprite . Please try hide sprite or move aside sprite in paint editor how there:

or just uncheck this box
you can keep the sprite shown, while not having to edit the costume. It's also a much easier option.

just wanted to comment on your code, it might be better to make the sprite go to mouse-pointer before setting the pen down. I'm saying this because if you only made the sprite go to the mouse when you click, it'll draw a line from where it used to be, to it's new location, but if you made it move before pen down, it won't draw that line. I know that's not an issue with your current script, but it might be better to teach the students to move the sprite before setting the pen down.


Welcome back to the forums!

The problem, I think, is in the color picker. If you try for blue, you get black, for some reason. Or at least that's what it does for me. Jens can't reproduce the problem.

Now I feel a little foolish. Of course the problem is that I'm dragging the sprite around rather than letting it move! I even had a note to that effect on the assignment I wrote -- I just hadn't read it because I "knew" what I was doing... Sorry to spam the bugs list with that. Thanks for quickly pointing that out.