(Maybe not bug) impossible to change drop-down options in effect blocks

I’ve tried multiple things but it seems that even doing
Doesn’t work, I’ve tried basically everything at this point that I can think of
But it seems that the fist drop down in both blocks isn’t even recognized by run with inputs.
It’s not an option in primitives
There’s no library for it
I’m going to assume this is a bug only for the reason that it’s incredibly strange that these are the only blocks that aren’t effected, even blocks that are hard coded like variables work with run with inputs but these don’t

If it’s not a bug than it really shouldn’t be like this, it’s really the only thing I can think of that holds snap back from literally being fully controllable with no restrictions

The problem is that the dropdown input is not empty.

This post never existed

Snap! substitutes only into empty input slots. This includes pulldown menu inputs. That's why every menu in Snap! starts with an empty value.

run(join(set ghost effect to 10)(color)(20))

That explains it!