Load failed

  1. Chrome
  2. https://snap.berkeley.edu/project?user=oliveoiler&project=Target%20Shooting
  3. My project shows "load failed: type error : cannot read property attributes of null" and is empty
  4. Not load the project when I open it or load it
  5. Load my project properly

Okay, so, right away, before doing anything else on your project, in the Open dialog box, click on the project name and click the Recover button. We may have a slightly earlier not corrupted version you can use.

Meanwhile we'll see what we can find out.

@jens @cycomachead @bromagosa The project file as reported by #dl: contains only this:

<snapdata remixID="8597716"><media name="Target Shooting" app="Snap! 5.1, http://snap.berkeley.edu" version="1"></media></snapdata>

I've never seen such a thing before -- what is it?

looks like an empty half of a project.

It means we don’t have the original project. Maybe recover will help here.

I had a student have the same issue, losing his project here

Did anyone make progress in resolving this issue?

I had the same problem, spent days on this project for my coding class

just made an edit adding to it and fixing some bugs, saved it, closed the page then realized I forgot to make one of the variables not visible. I went to my project page and tried to open the project and that error popped up, when I tried to recover the project, it said it could not fetch any versions of the project.

Im having the same issue with my code. https://snap.berkeley.edu/project?user=arvain&project=Smash

I have worked on this for some time already and its not allowing me to open, or modify my code. I have already attempted in recovering my code from previous versions but for unknown reasons they return the same error.

We've just now installed the patch, you should be able to open your projects again. Sorry for the hassle!

This just happened to me after I tried to rename my project. The project is due in two days and I have no idea how to recover the code I spent several weeks on.

What are the old and new names?

I don't think the name changed successfully, but here's the link to the project:

Yeah, this is an empty media file. We've seen this happen before. I'll try to get someone competent at the database to look for your project. Might take a little while since people have been off on vacation.

Ok, thank you so much. Could it be because the project isn't public? If so, I can make it public.

No, that's not the problem. It's happened to other people but I'm not sure we know why. Sometimes projects are recoverable but sometimes not.

Oh, ok. Let me know about any updates!

I think the file is still there but is corrupted or something? The saved final version is still listed in my projects and doesn't appear to have been edited.

The file that's there is a media file (as opposed to a project file) with nothing inside it. If you saved an uncorrupted version earlier, and you don't try saving again, then maybe it'll be recoverable. I'm sorry, I know you're worried and you have a right to be upset, but I can't do anything more at this point.

I have previously saved uncorrupted versions of the project (I haven't saved the empty version).

Sorry to bother you again, but are there any updates? In your previous message, did you mean that you personally can do or that nothing can be done in general?