Load failed: TypeError: cannot read property "attributes" of null

I was making my final project for school on Snap!, and tried to open it today. It gave me the message "Load failed: TypeError: Cannot read property 'attributes' of null" and opened a completely blank project. I have no recoverable files. I used both Edge and Chrome, they both gave me the same problem. This is a very important project, my final for the whole class, and it's due in a couple weeks. I'd really appreciate any help, thanks.
The project link is https://snap.berkeley.edu/project?user=colins26&project=Final%20Explore%20Task

Just to note, I've been working on this project for six months. I've put countless hours into it, and I really can't lose it. Please help.

The last time I saw the project complete and working was this morning, May 10th. The link is shared, it should work.

make sure it is shared, I clicked the link and it said, "project does not exist"

That is the problem - over 6 months of work is missing.

I shared it at the same link.

Okay, I retrieved your project, but when I try to save it, it saves with its costumes missing. You can save it on your own computer (push the "Computer" button in the save dialog).

I tried uploading here but the forum thinks it's a picture. So I put it here:

I'm sorry you had this terrible experience with Snap!. We're working on the problem.

P.S. Don't you mean Create Task? :~/

Thank you so much!!! I had most of the costumes saved to my computer, so that's no problem. And yes, I did mean Create task, but when I first made the project I didn't know the difference.

Why are two posts flagged? I don't think any of them are inappropriate.

They were automatically flagged by the forum software, which noticed two users at the same IP address and decided they were sockpuppets. I unflagged them.

Ah. Thanks!