LIST Question

Why does this custom block not return my List?
Yet it says it !
It also does not work if I report the MAP block directly, without going through the localList variable.

I don't understand what your complex expression inside map is supposed to do. What's the outcome you expect?

Oh, now I see the problem! Duh, let me look into it...

Hmm... I can't reproduce this. Works for me, very funny... Can you share the project with me?

There is no project ! Just the codeblocks I have attached.

The actual use was for a local list generated in a custom block and added to a global list.
However, as in this example, I was able to SAY it but not Add/Replace it to my global list.
That's when I noticed that the list was NOT being returned.

So I tested it in this fashion, based on the code sample from Joan (MAP). I also tried it with regular Add three items way. Neither worked. That's when I asked on the forum.

Here is a different version using Numbers from:

WIN10 Home 64bit and
Google Chrome is up to date
Version 83.0.4103.97 (Official Build) (64-bit)

Here is even a stranger one:

makeList DOES NOT work, ReturnList works !!!!

Hmm... are you sure the report block is actually attached? Because it totally does work for me, or am I missing something:

Absolutely the report block is attached.
Here are two sprites each running a SAY with the differrent blocks.

Okay, I give up. Can you please share the project with me?

Funny! This project works fine for me, no error. Also using the very same Chrome 83.0.4103.97 (Official Build) (64-bit) release on MacOS.

What else can I verify ? Any settings ?

Naw, none of that should make any difference - and none of it does. Maybe reboot your computer and restart Chrome. Looks like something is broken in your Windows...

Just loaded and ran it on 5.4.5 with NO ERRORS.

Will reboot and report.

OK, Now all is working again !

Haha! It's really a joke, but the old IT Crowd mantra of "did you try turning it off and on again?" really does work. As a consolation, this also happens to me on my Mac a lot, not just on Windows...
(a couple of days ago I was panicking because the Snap! site was super slow for me, except on VPN. I harassed @bromagosa about it all day until I finally rebooted my router, and that fixed everything :joy:)