Last letter unavailability glitch

Whenever I want to delete everything and click the end of the text no matter how hard I try it’s not going the the end and ends up like this

Snap! 6.3.1 Build Your Own Blocks 2

And I also realized it’s not the actual cursor, you think that has something to do with the glitch?

Yeah, this is a known problem. On the list...

What do I do?

press the right-arrow key to move the cursor! That should help.

I’m on ipad and I can only do that on my Android, maybe make it your actual cursor? I figured that out because it’s not blue and that bold

Ah, let me check on my iPad. Thanks!

okay, I've found the bug. This will be fixed in the next patch within the next couple of days. Thanks again for reporting this!

We've just published a patch with - among other things - a fix for this bug. Could you try again and let us know if it works for you? Thanks!


(I'm just so excited, and btw, it's fixed, well, at least for computers)

Yes, that's awesome! A longstanding small annoyance solved. Thanks!

Oh no the glitch is still there (it’s still not my cursor)

Never mind I just had to reload the page

well, the fix has been what your bug report was about: "Last letter unavailability glitch". Now you can reach the end of a multi-line text using a mouse or finger-tap:

Snap! uses a hidden input element to interface to soft-keyboard, mainly because the way to program the web is horribly broken. One way to see this is that in iOS you sometimes see the "hidden" input element, and also the caret that is supposed to be hidden by the browser, but which Apple won't hide anyway.

I'm closing this thread now. Thanks for the report!