I uh.... broke snap again

im making a block library called jblocks which ill explain upon release
and i copied a block called " (input 1) " to make it ' (input 1) ' as shown.
i tried removing the text and stuff and got this
so i was like "oh thats weird"
so i made a new block with the same plan, pressed okay.. and now the operators category is broke

This looks like a result of a snap mod error, but this is vanilla snap

Putting apostrophes in custom block names breaking snap is a known issue, and has been known for many many years. I don't know when (or if ever) it's gonna be fixed, but it is a known issue.

oh, fr?

(insert rant about the long, sad history of in-band signalling here)

It would be better if you tried hard to use meaningful thread titles.

Yeah, scratch 3.0 uses it, even though they have been working on scratch for decades, and have large team working on it. Seriously, if you type %n into a custom block, it breaks the palette when you press ok (and it doesn't even close the custom block dialog).

I wish block based programming languages stored the block name as a list, the labels and the inputs, that way there's no string parsing required to find the inputs.


Oh that’s happened to me before save your project then reset snap