I Lost All My Code

  1. What browsers show this problem?
  2. Please share an example project (if possible).
  3. Describes the steps to reproduce this issue.
  4. What does Snap! currently do?
    Does not show the message called "Start" and deletes all my code when I reload the project after saving
  5. What should Snap! do instead?
    Should show everything properly

Sorry to hear that you lost your work on your Snap project. It's probably just a server error or you just forgot to save. I doesn't automatically save and it's also better if you save and backup locally as well.

Have you tried recovering it?
(If not and you don't know how to do it, File > Open > Word Processor > Recover)

I'm sorry you lost your project. Did recover work?

Are you saying that just having the scripts shown in the screenshot you posted is enough to cause this bug? I am unable to reproduce that. I can't reproduce it in your example project, either. Was there something else going on that might contribute to the problem?

I don't know. I was playing with your wordplay project you showed in YTLF, at first and worked on another project which I did not save and replaced the second one with a new one, which caused the bug. I do not usually work on Chrome nowadays. Could that be a clue? And can you see the code now? (I have not recovered the project yet.)

I will try that.

I know that.

Oh, and one more thing, I had resized both the block pallette and stage.

Recovering the project did not work. :frowning:

Yeah, I just checked and we have no nonempty backups for that project. I'm sorry. I think you somehow managed to save a new project (new as in empty) over the old one. I suppose resizing the UI parts could be relevant somehow, but I don't offhand see how.

I see. :cry: