How might I connect to Minecraft from Snap?

On my repl, it just flat out refused:

Could not connect to server: wss://
Could not connect to server: wss://

can it connect to my repl?

/connect wss://

edit: it's now saying that it couldn't connect.

Nope. It gave the same Could not connect to server error pretty much instantly.

I don't know why, but it's also giving me the error, which didn't happen before.

I also tried /connect wss:// and it gave the same error.

Also, /connect ws:// gives Connection closed sometimes, other times it's giving the other error.

Doing /connect takes some time then gives the error.

If this:

Failed to open a WebSocket connection: empty Connection header.

were fixed, it might work.

yeah, I stopped the server so of course it gives an error.

I don't even know what a "Connection header" is, much less how to make it not empty.

(yes kind of a bump)

I tried that but it didn't work. None of the Python files worked. Can you give a step-by-step tutorial on exactly how you got it to work?

I have a feeling there's nothing wrong with the server itself, but rather with Minecraft itself.

Edit: Got it working on localhost.

Edit 2: but not on replit.

There are other ways to get apps on iOS/iPadOS

I know.

Basically all I need to do is know these:

  1. how to communicate with Python from Snap!
  2. how to make it work on replit.