How do I get Byob to work on Ubuntu?

The instructions here don't work. I have Scratch working, but if I try to open Byob I either get an error from Squeak or I don't, in which case I see a window, but it's just white.

BTW the Ubuntu I'm on is 22.04 Jammy Jellyfish.

In olden times, I worked with Tim Rowledge (who did the Scratch 1.4 speed ups for the Raspberry Pi) and came up with this installer.

Just tried in on my Linux Mint VM (Ubuntu derived) and it works with some small changes to the hard-coded /home/pi folders

download the installer

wget -O

and then edit the file and change /home/pi/ to /home/yourusername/
in the first few lines

Also change

chown pi:pi /home/pi/Desktop/BYOB.desktop

chown yourusername:yourusername /home/yourusername/Desktop/BYOB.desktop


sudo bash

Thanks! For some reason, if I maximize it, it goes black, though.

So it does :frowning:

Just manually adjust it's size as workaround :slight_smile:

It also seems to think the window width is a lot smaller than it really is.

For example, if I have it this wide:

it thinks it's only 163 pixels wide.

Also, how do I open it in development mode? The way the Windows BYOB Development.BAT file does?

run this from terminal

bash /usr/bin/BYOB %f dev

and then shift-click on Edit

Thanks. Another thing, though: I can't save projects--I get "Save failed: Unknown class VariableDeclarationBlockMorph".


Mine works

Try re-installing - you may be lucky 2nd time

Thanks! That worked.