How could I connect Snap! to a MIDI device?

The title.

Spookily, I'm just about to connect my midi keyboard to my PC so I'll have a play with trying that out

I'd start with looking for a javascript midi api.

And I have mine connected right now!

I've got mine connected up and playing/recording using some Midi software on my Windows 11 computer

But I was hoping that it would show up as a serial device but it doesn't :frowning:

I was going to test that but FireFox doesn't support serial ports.

It's now a lot easier in the dev version: new TuneScope extension and library, thanks, Glen, Eric, and team!. But there's a bug where if you run this:


it makes it sound like a piano and a guitar, combined.

[offtopicish]
I managed to play the treble part of the first several 9 measures of Für Elise with only my right hand. It wasn't easy. (G4 instead of A4 is one that trips me up.)
[/offtopicish]

Did you have to do anything to get your synthesiser to show up in the options? (as mine isn't appearing)

What OS are you running?

I'm on Windows 11 and using a Yamaha PSR-EW400 just connected to my PC with a USB lead

Yes ... we put a couple of the keyboards that we are using in the dropdown menu. For other keyboards, you can type the name of the keyboard / MIDI controller into the input slot. (As popular keyboards are identified, they can be added to the dropdown menu.)

As noted above, there are couple of bugs in this block. We got it working at the last minute just before the music blocks were added to the dev server. So, if anyone has thoughts about resolving the bugs, that would be helpful.

After you plug in your MIDI keyboard, go into Windows Settings and then Devices. You should see your MIDI keyboard listed there.

In Snap*!*, you can type the name of your device directly into the "Play MIDI" block. It should be typed exactly as it appears under your system devices. If you want, you can also edit the block to add your device directly to the drop-down menu.

Thank you :slight_smile: Working now :slight_smile:

image

Great! Evidently the webmidi library created issues with Snap!, but Jens and @bromagosa are working on a fix. (Thanks!)