Custom command blocks with multiple inputs issue

  1. Vivaldi Browser/Win10 & Chrome/Win10
  3. Create command block with multiple inputs and drop a reporter into the input
  4. If you subsequently delete/edit part of label - the reporter gets thrown out
  5. Leave the reporter in place

I failed to reproduce this.

mm -Interesting
Did you try my project?
What browser/OS are you using?

Yes, I tried your project. Right-click on the command block, edit the parameter name, click Apply, and the join reporter is still in the command block.

I just asked a friend while we were on a zoom meeting to try it out and theirs did the same as mine

They were using Chrome on a Macbook

Oh yes, that's a known loose ends. things inside multi-slots get lost when you edit the block's signature.

How did that not happen when I tried it?

did the join reporter disappear? that's what happend to me.

What happens with me: (read it like a table)
Add:_______join disappears___join disappears
Edit:_______join disappears___name: join is still there, type (still multi): join disappears
Remove:___join disappears____join disappears

ok, I don't really get it. This is what happens to me

(if it doesn't show up here's the video link

It's supposed to be a table.

I still don't understand it

If I edit a parameter name, the reporter stays in the input slot. In all other cases (edit a parameter type or a label, add a label or a parameter, or delete a label or a parameter), the reporter disappears.

Do html.

I could, it's a bit tricky to work with, and I thought it wasn't worth the effort to do it in the forum post.