Cloud outage?

I can't save this project, it's not showing anything other than "Saving project to the cloud..."
Screenshot 2024-03-17 16.03.14
I'm not aware of any more information I can provide, I think I should mention that I did run this script, which might have been the cause.
OSKBD script pic
OSKBD script pic (1)
OSKBD script pic (2)

In all fairness, I probably should have asked if using Snap's letter avatar thing was also against the rules like trying to access the cloud.

I feel like something else worth noting is that when I press ctrl+s, it also displays the dialog for saving the page. like I had caps lock on, as apparent from the text I am currently writing, that is not the case.

I also tried saving from the menu dialog option, same thing

What is this?
Screenshot 2024-03-17 16.16.57

All of the code in the project:

I tried getting a result pic from the only variable in the project, but I guess it should be obvious what it is set to given the scripts. The variable was also marked as "transient"

All I can tell you is that I'm able to load/save projects without an issue so its not an issue affecting everyone.

The first thing to do is export the project, so you have a local copy of the project.

I have a feeling that the costume from url is indeed the problem. Try deleting the costume, and then saving the project.

I hope you don't mind, but I'm going to use this as a primer on debugging.

  1. "I can't save my projects," plural. Oh, but wait, this is a weird project. So, before reporting a Snap! bug, maybe try saving some other project? Open a fresh Snap! tab, drag out a MOVE 10 STEPS block, and hit ^S.

  2. Okay, so now we know there's a problem with this project, rather than with the cloud. Two problems, actually: the nothing-happens problem and the SecurityError problem. And, from what I can see, two candidates for the cause: the LETTER COSTUME block and the clipboard.writeText JS function. So, make two new projects: (1) one with just that JS Function block, and (2) one with just

    and see what happens when you try saving and/or exporting them (after running the block). Then you can start doing web searches to see why whichever candidate problem it turns out to be isn't savable.

That's a Dialog feature, not a Snap! feature; I had to search to find out what it does. I don't think it hurts us for you to do that, as long as you don't flood the forum with requests.

I made another project which uses the clipboard feature, so it's most likely something going on with image urls.

It usually is. I was messing with the block and tried to get a costume from an emoji and that's exactly what happened.

My educated guess is it was trying to save a tainted image as a data URI, as it does in the project XMLs, but it can't, because it's unsafe, so instead of saving, it stalls.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.