Changing the "letter () of []" reporter to "character () of []"

Currently, there is a block that looks like this.
This block reports the ___ letter in a string. However, it also works with numbers and symbols, so I suggest changing it from "letter () of []" to "character () of []".

That would certainly be more precise. We use "letter" because it's a word everyone knows, while "character" in this sense is an obscure technical term. (Say "character" to most people and they're likely to think you mean a sprite and its costume.)

So we're unlikely to act on this, at least not unless/until we undertake a total overhaul of what's in the palette. The people, like you, who do know what a "character" is in computer science understand perfectly well what the block does, regardless of how we name it.

changing it to "char" would worsen it

I would become super confused about that, also, the people coming from scratch would be looking for the "letter" not "char" or "character". It's best if it doesn't get changed.