Bug with saving

I have been working on a Solitaire clone for the last week, and when I reloaded the page (after I had just saved the code for interacting), everything showed up as
Solitare script pic

I have NOT saved since reloading. Any ideas?

i think you could try to use this button in the open project window, but i'm not sure of how it works or if using it has any risks so i recommand first to check if there is anything about it in the forum or in the instruction manual

Recover did nothing.

idk then :confused:

normal link to open snap
goto file\open


Maybe you program it in dev mode

click the dev mode link and try to open your project

if it work, "save as" with a new name !

I saved it in the most recent stable version, Snap! 9.0.14. It just will not work :frowning:

This is very strange. Normally undefined blocks are colored red but this one is grey. So something must have gone super wrong with this

The reporters are red in a different script (randomly generating cards).

The one I posted wasn't a custom block. It was a huge if ... elif ... elif ... elif statement.

That’s likely the issue then, something must have happened with versions getting mismatched because that block only exists in 9.0

Still no idea how the undefined stack block turned grey, whenever I got it it’s always been red

I wrote it in version 9. This is version 9.

Ik, that’s why it’s so weird, some kind of mismatching between versions must have happened

They were recolored to gray,

Well that explains it

try to clear cache in your browser

I already tried that.

can you share a link to the project


I rewrote the Undefined parts. The if at the end used to be much bigger.

cool project by the way


The current Snap! is 9.1.0, as of last night.

I think you must be using two computers, or two browsers, one of which has had Snap! loaded today and therefore has 9.1.0, and the other of which has an older version, either still running from yesterday, or still cached. You should look at precisely what version you are running (:snap: > About) on all browsers and tell us.

There should be no problem loading a project from an older Snap! into a newer one. You get Undefined blocks loading a project from a newer version into an older one.