A block not working in my custom blocks project

I tried exporting

to my custom blocks project, but I got custom blocks script pic(23). however, when I use it in a new/blank project it works. sorry if this is not a bug!

Weird, I'm actually getting a different error on my end (in your project).
image
This error usually means there was a problem with rendering a block. It worked for me in an empty project, and that implies that the only custom block is the block itself.
What project did you use the block on? Were you tampering with the global blocks array?

Also, in your project the image uses the raw blockTemplates function, which means that the blocks in the lists aren't reified, and the list also includes buttons, checkboxes and syntax. Definitely not usable without modification.

I added it because I like it, that's all.

nope.

You've messed up with categories and created a few, now invisible, custom commands in the "category" category ...
Bez tytułu
It breaks when blocks are forced into the ring with "new Custom...".

I don't have that category.

?

where did you get that block???

I was just about to ask!

They're not talking about that category specifically. Just that you have an extra category somewhere and it's messing up the block.
Cannot read property 'lighter' of undefined means that it's having trouble rendering the colors for the extra blocks, since they dont exist in the source code.

so they have an extra category that it cannot report?

yes

Aha! Got it!


This script is used to find the category of each custom block in the project. As you can see, there is one block with a category called "hi" and several others with the category of "category."
@sathvikrias import a module, delete those blocks, and remove the category and it should work
Edit: also found categories 'test', 'invisible', 'New Category', and 'Error Handling'
Edit(2): Deleting all the blocks in the categories did make the block work

why is there a zillion operators and what is the hi category

beats me. I imported a category building module and the 'hi' category just has a single command block called 'hi'
prob just them messing around

weird

yep

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.