Snap! v7.3.1 Patch

We've just released a little patch that addresses the occasional issue of not being able to load a saved project. Please make sure to update your Snap page by doing a hard-reload either by holding down the shift key while clicking on the browsers reload button or by pressing [Ctrl]+F5 on a PC. Afterwards the Snap version should read "7.3.1".
Sorry for the flutter of problems some of you have encountered.

[edit] There is currently another problem with the cloud backend involving to not being able to save projects. This problem is unrelated to the v7.3.1 patch (in fact, it's unrelated to the Snap client). We're aware of this, too, and we're working on it.

My project is broken !
(exactly when you perform the update ?)


If it helps: I was running my program, the sprite panel went black, then the block panel went black, unable to save... Then I tried to reload my program: broken...

hmm... this seems to be a different issue, unrelated to the patch or to the its problem. In this case the project file got broken, probably when it was "unable to save", and I frankly don't know how that happened. I'm seeing a ton of custom JavaScript code in this project, does it use up a lot of system resources? Chrome has gotten very picky about these lately. Can you try recovering an earlier version?

i think only 3-4 blocks use javascript but i don't use it for now in the project.(layer system)

No, that's the only one version.

When i got the bug, these buttons does'nt responding...

okay okay but i didnt
Screen Shot 2022-03-16 at 6.01.08 AM
take these
Screen Shot 2022-03-16 at 5.53.58 AM
Screen Shot 2022-03-16 at 5.54.19 AM
for nothing


glad i saw this ,and didnt go down that rabbit hole of trying ever more obscured methods to fix a problem thats really mostly trivial, in some world where id be just, doing things the easy way.... i know ik crazy ideas.



Can't make a thread in the bug report section, so I'm posting here.
I managed to break the audio by playing a background loop and sfx at the same time. Please fix the audio issues with Snap.

I am unsure if this is related or not but I have several students reporting that they can not open their projects. They get a message that reads something like "Unable to open project. No attribute after name = " They can recover projects from a few days ago but nothing saved yesterday. Do any of you have any suggestions? We tried the hard reset and clearing browser history.

See This Morning's Cloud Saving & Loading Issues

We are using Birdbrain Finch and Hummingbird Robots & have been encountering lots of errors since the patch. Some missing block definitions and more.

I recommend pushing code updates out in the summer so that any bugs don't derail classes.

Tell them to export their project and then import it back into snap

How did you solve the problem and/what is the problem. Im having the same issue

good thing I played too much fortnite with my friends lol (I haven't been using snap lately)