Script pics have not been working lately

Yeah, I have a folder on my desktop, but what I'm trying to tell you is downloading from the forum is a game of roulette, so I usually just don't.

I'm guessing that the issue is that some pictures are zoomed out (reduced size) in the forum, and those are the ones you can't import. If I'm right, just get in the habit of double-clicking the picture before dragging it out.

I'm aware of that, and more often than not, that does work, but it's still a hit or miss thing. The thing is, while I know to do that and it still misfires 50/50, what about the person who doesn't click the zoom and doesn't even realise the forum shrinks images, they're going to have the feature fail 100% of the time and decide it's broken and wait until another version of snap, still have the issue and assume it's a fake feature or whatever.

You can't assume things

Yeah I get that. As a practical matter, it's all we can do to keep up with Snap! itself; we can't do major development on the Discourse software. But yes, it'd be way better if dragging a picture out from the forum automatically gave you the full-size image.

Forum software, for the resized images, shows the visual hint/clue

.
There is another problem. Smart pics may not work for Firefox because of the drag-and-drop handling inconsistency.

EVERYTHING MAKES SENSE NOW although it happened to other people too

I've seen corrupted images with the XML stripped or evident file modifications.
It seems to be the man-in-the-middle problem, eg., the national proxy/firewall or the internet provider, unwanted, bandwidth optimization, which leads to the malfunction.
Or modified Snap! instance...

I haven't really tried it much because Firefox for ChromeOS sucks to use, but in my experience it worked

I've just tested FFv.127@Win10 and it does not work - a tainted image warning is displayed.

Do you have an "Allow CORS" plugin?

I mean it's basically impossible to move images from one tab to another on FF@ChromeOS but downloading it from the forums and importing it in Snap works fine

no?

So next time, let us examine the PNG file that can't be imported.

  1. Check if the file on the local disc contains "Payload" or the whole sentence "Data Payload Embedded" near the end
  2. Check the file served by the forum

If they differ something changes the file in between.

I think I'm agreeing with you on letting libraries include customized primitives. Yes.

I'm more worried about users loading two libraries that change the same primitives. Maybe show a popup showing which primitives are being imported?