Recurring iPad touchscreen issue

Often, after I've used the IDE on my iPad for some time, when I'm touching the screen with my finger, it doesn't "hit" the block or menu option that is being displayed on the exact spot my finger is at. Instead, the IDE behaves as if I'm touching the screen about a quarter inch below. It's virtually impossible to get things done this way.

I tried turning the screen sideways by 90 degrees, and back, but that doesn't help a bit. The only thing that does work for me is saving the project (which is difficult enough), closing the IDE and often even the browser (Safari on iOS), and trying again.

Is this a known problem? Any workarounds?

It's not just touchscreens; I have the same problem using the mouse on my Mac. But for me it isn't permanent like that, just momentary.

this is interesting, because this often happens on my pc, but I thought it was just a me problem. I can just restart snap though (reload page)

Huh, I only get this issue whenever I'm on mobile, and the page somehow gets resized. I don't exactly know how to recreate the issue, but it has never happened on desktop (unless I run out of memory, and the browser messes up snap, but that's a whole other issue).

Does the page happen to look slightly stretched vertically?

It does indeed!

Yeah it happens to me too. No idea why it's stretched though. Maybe try using a different tab? Works for me sometimes

Please explain.

I was being serious for once, it’s an annoying issue (to me, at least), and I haven’t encountered it outside the Snap! IDE. Oh well, I have now understood from another topic you’re a very young person, so I’m not mad or anything. :slight_smile:

ive never actually encountered this issue... its only happened when something i did broke snap and the ide freezes and resizes and the menus are in the wrong spots. and that hasnt happened in a long while.