Pick good names for your vars and functions!

You can use spa ces for var and function names.
So the best way to name them is to add a spa ce between words and no UPPER case.
Don't forget to add labels for functions!(I've seen a bunch of people using foo(bar:%bar,baz:%baz) for function foo maybe because they program in other languages like JS and are not used to Snap labels in the middle of a function(I'm that kind of person too :frowning: ))
Good:
[scratchblocks]
(my variable)
my function ()
glide to sprite [ v] in () secs::motion
[/scratchblocks]
Bad:

[scratchblocks]
<(MyVariable)or(myVariable)>or(my_variable)
myFunction\(()\)
glideToSprite\([ v],()\)
Glide_To_Sprite_[ v]In()Secs
[/scratchblocks]

haha...myVariable reminds me of how everyone makes a var in JS....on KA....

Yeah,camelCasing is good in JS.

I use the myFunction() notation for maths stuff such as n P c (that can be written as P(n, c)). Having ( ) at the start of a block just doesn't feel right