Layout created in a big monitor does not fit in a built in display from a laptop.

I have created a demo application displayed in a separate monitor , but when I tried to reproduce the program in a laptop, I can only see a portion of the layout.

  1. Browser: Firefox
  2. Project cannot be shared due to its size (the software does not allow me to upload since its 20M)
  3. Project created displayed in a separate monitor with a backstage created with a high resolution of 1920x1080 and jpg pictures. Picture occupies all the backstage area.
  4. when opened in a laptop built in monitor does not display fully, just a corner of the project.
  5. It should display the full project, not just a portion, independently of the monitor used...

I dont know if this is a real bug or something I have missed in the process but your help will be greatly appreciated.


Hello! Welcome to the forums! :wave:
Could you please tell us what your operating system is and share the project with us? And is your project packaged with something like Snapp!? If you open the project in the editor, by default, your project's background will be the only thing to show up on the right corner, and there will be blocks, scripts etc. on the left. Is this what is happening to you? Here is how the editor should normally look like-

Thank you very much for your answer :slightly_smiling_face:

I am working on Windows 10
I can send you a wetransfer for the app I generated from Snapp! if that helps:

Otherwise this is how it looks the editor in my big monitor:

and how it looks in the laptop:

which is the look i get also on snapp! generated file...

It does seem like a bug. @Jens or @cycomachead , you might want to take a look here. In the meantime, I think you could test with the Snap! 6.0 beta version.

This version runs much more smooth than the previous one.
I had speed issues with this project and so far is behaving much better.
Thanks for your help.


The layout issue is still there though... :pleading_face:

This looks to me like a retina display problem. Could you please, on your big display, click on the gear icon (shift-click on it if you're in the 6.0 beta) and uncheck the "retina display support" option near the top of the list? Then make a background and try using it in your small display. Let us know what the result is. Thanks!

I have disabled the retina display option but I have lost the menu for the blocks on the left and half of the middle menu as well
This is how it looks like...

I tried to zoom out the browser but they wont come back...


did you change the stage dimensions to be huge? That would explain it.

Yes, I did... is there a way back without restarting the project from scratch?

Sure, turn retina back on, and/or change the stage size down.

I have to rearrange and redimmensions sprites but looks like it works.
Thanks a lot for your help :slight_smile:

Sure, that's not a surprise; when you design for a high-resolution monitor and then you want your project to run on a low-resolution monitor, of course things are going to get crowded. Anyway, I'm glad it's working for you.