Export block(s) didn't saved everything

  1. What browsers show this problem?
  2. Please share an example project (if possible).
    I can not upload .xml files to the forum
  3. Describes the steps to reproduce this issue.
    Worked some time on a project. Then I tried to upload it into the cloud, but it doesn't really work. Than I tried to save it otherwise. Export as .xml doesn't work! It said "Export failed: TypeError: atomicValue is null". But the export blocks-button works fine. So I saved my data. Later, I worked on the project with the data saved in the blocks, and again the same error occurs. So I exported my project data again in some blocks.
  4. What does Snap! currently do?
    After opening the saved blocks again, mostly everything was gone.
  5. What should Snap! do instead?
    Show me all blocks I saved

Hi @f_m_fmbg,

But your blocks xml file is fine. I've load it and an I see 12 custom blocks stored.

Had you got more custom blocks in that project?


Hi Joan,
the problem is that I have put the script in the two grey blocks. But the most of it is gone.