Error - "You are not logged in"

I teach a high school "Intro to CS" course. I had roughly 75 students sign up for Snap! in the last 3 days.

Multiple students (around 3 out of 75) have run into the error that they cannot save their project. When clicking on the cloud button, it shows them logged in (the option is to logout their user). When they try to use the file menu to save/open/save-as, it does bring up that popup but also brings a red popup window over it that says "Snap! Cloud. You are not logged in"

Using incognito window of Google Chrome on 64bit Windows 10 machines.

Things we have tried:
Logging out and logging in without closing the window. This has not reliably solved the problem.

Thins that work:
Closing or reloading the entire window, but then the entire project/progress is lost.

Thank you!

I'm sorry you're having this problem.

First of all, if this happens you should use the File>Export Project menu item to save the project to your local disk. This will eliminate the possibility of losing it.

I wonder if incognito mode is the problem -- does it disable cookies, or change the IP address between transactions?

Anyway, if you send the Snap! user IDs we'll look in the log to see what we can discover.

I suspect that incognito is the challenge here. If that happens, you should click logout and try logging in again.

We definitely need to improve the experience in Snap! here. I’ll make a note.