Click area of arrows overlaps with Input fields, add mouse over state to blocks

This is an annoyance I stumble again and again:
Large GIF (290x138)
Almost every time I try to click an input field, instead of clicking the input field, I end up clicking the left arrow. The click area of these elements is very very small.
If you play the animation, you'll notice the mouse is closer to the Input field, but instead the Left Arrow is clicked.

I'd appreciate if there was, either:

  • A wider space between the input field and the arrows
  • Make the arrows larger, and farther away from the Input field
  • Bigger input fields, wider
  • A mouse over state, i.e. make the Input field darker when the mouse is over them, and also make the arrows highlight on mouse over

That would help the user, they'd be sure what is going to be activated on mouse click.


Everything in the GUI is a compromise :slight_smile:

I use zoom 1.2 to make things big enough to see and click on

But probably going to have to move up to 1.3 shortly :slight_smile:

Thanks @cymplecy, will try the Zoom setting

Ah. We do do that, when you're dragging an expression over the block. I suppose we could also do it when you aren't dragging an expression.

I moved this from "bug reports" to "feature requests," where it belongs.

@dardoro Infinite infinite thanks, extremely frustrating arrows! appreciate your help and recognize it's not only me :rage:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.