Bug in 7.0 when opening projects

Whenever I load a Snap! project in 7.0 it gives me this. And sometimes even a little box in the top left corner. This is example is from helicoptur's(do I ping him?) Bounceathon. But even when I open up a 6.9.2 project and put the /versions/dev/ it gives me this. This is the console when I load the page:
Does anyone know how to fix it?

What OS/Browser are you using?

Do you have access to another device to see what happens on it?

Windows 10, Chrome. And yes, it works on my laptop.

Not seeing that effect on my win10/ chrome

Can you try another Chrome based browser such as Vivaldi?
Also check to see if up to date on Chrome

See Debugger (F12), Console tab for errors.

I'm don't know how to get there but I think it's up to date because it doesn't display the "update" button in the top right.

"api.js" is usually used by the external page hosting Snap! instance.
Do you have some user scripts installed into browser? Or start Snap! in a non-standard way?

Nothing was installed on my browser. I didn't even know you could install code into your browser. The way I open I Snap! link is by clicking on it. The way I open Snap! is I have it bookmarked. The way I run Snap! is by pressing "Run Snap!" and I go to the forums by pressing "Forums".


You may try to close other browser instances and start fresh one only for this project URL. Browser console log shows, that Snap! tab receives a malformed message, that mess with the process of project loading. So if You do not experiment with window.postMessage yourself, other page or even Snap!/JS project can send a a spurious HTML broadcast.
Either way Brian, Jens should look at this. But I'm not sure if public bug reports, for unreleased version, are welcome.

And have you tried switching your computer off and on again? :slight_smile:


As for that, I don't have any other browser but Chrome and Edge.

And what happens in Edge?

Weird. It works in Edge. It also works in Chrome just now. I don't know what happened. Or what I did.