Anyone know why once I save why the predicate blocks are becoming undefined?

When I was putting the snap program together everything was fine however once I save and opened that saved file the predicate blocks became undefined. Does anyone know why this is happening?

I forgot to type it but when I save to the cloud this doesn't happen

can you share a link plz and a script pic on the predicate block

Hi, welcome to the forum. Sorry about this problem, but the project is okay (unless you saved it with undefined blocks, in which case you should Recover the project after fixing the underlying problem, which is that your browser has old Snap! code in its cache. To fix it, hold down the shift key while reloading (↻) Snap! into your browser.

I tried putting the photos of what happened inside of this but it said an error occurred but something weird happened the problem I had fixed itself so I think it might have just been with my computer.

Again, the problem was that your browser cache had an old version of Snap!. There's nothing wrong with your computer.

I'm teaching high school CS using snap & am having the same issue when trying to grade my student's work. Their code runs fine on their machine, but when I try to see code on my machine, I'm getting Undefined blocks (not able to attach images). I've tried holding shift & reloading, but that didn't work... any other suggestions??

I've found that holding shift, and clicking reload sometimes doesn't work. To be sure you're clearing the cache (in chrome, idk about firefox), open the dev tools (f12 or ctrl+i), then right-click the reload button. There should be new options that pop up. Click on "empty cache and hard reload".


I'm having the same problem, but I've tried clearing browsing data multiple times in multiple browsers and it still doesn't work. The code always shows up completely fine on my Mac but not on a Windows...

in which browser

It shows up completely fine on my Mac, in Chrome, Safari, and Edge, but not on Windows in Chrome.

And what happens on windows using Edge?

try it with only 3rd option , if it don't work, try the 2nd option
(i think with option 2, you will have to login again on the snap site...)


You just need to clear the cache, not the cookies and site data (or browsing history).